Naar content
Trending apps
  • Inbox by Gmail

  • Maps: Navigatie en OV

  • WhatsApp Messenger

  • Messenger

  • Facebook

Trending games
  • Minecraft Earth

  • Dr. Mario World

  • Harry Potter: Wizards Unite

  • Breaking Bad: Criminal Elements

  • The Elder Scrolls: Blades

Trending smartphones
  • Realme X2 Pro

  • Moto G8 Plus

  • Microsoft Surface Duo

  • OnePlus 7T Pro

  • Nokia 7.2

Nieuwste tablets
  • Samsung Galaxy Tab S6

  • Samsung Galaxy Tab A 10.5

  • Samsung Galaxy Tab S4

  • Samsung Galaxy Tab S3 9.7

  • Asus Zenpad 3S 10

kwint

kwint

  • Lid sinds 05 april 2012
  • Berichten 11
  • Reputatie 0
  • #1
  • 2 juli 2012
  • 22:24

Hoi,

Ik heb mijn htc desire geromt en wil nu graag A2SD kunnen aan zetten,
volgens de rom maker moet ik een partie hebben op de sd kaart en dit heb ik gedaan.
Dan moet ik in de terminal SU typen (na wat googlen kwam ik er achter dat dat betekend dat de app dan vraagt voor root toegang of iets in die richting) wanneer ik dat doe krijg ik de volgende foutmelding:

reloc_library[1314]:  2238 cannont locate '_mktemp'...
CANNOT LINK EXECUTABLE
Ik heb super user al geupdate en updates weer verwijderd.
Ook heb ik geprobeerd om deze stap over te slaan, dan krijg ik als response:
This script must be run as root
aborting

Weet iemand waarom dit is en hoe ik dit kan oplossen?
Alvast bedankt!

Bewerkt (24 april 2013 15:08)
Marvin

Marvin

  • Lid sinds 30 december 2009
  • Berichten 1778
  • Reputatie 10
  • #2
  • 3 juli 2012
  • 10:48

*** Zwaar technisch verhaal alert ***

Dat is een aardig technisch probleem dat je vermoedelijk niet zonder meer zelf op kan lossen. mktemp() is een functie die in de system library van het systeem hoort te zitten. Bij het starten van een applicatie wordt de binary van de app van disk gelezen, worden absolute adressen ingevuld (“locating”) en referenties naar deze library worden opgelost. De locator meldt nu dat de functie mktemp() (of eigenlijk het symbol _mktemp) niet gevonden kan worden. De oorzaak kan zijn dat de library niet past bij de kernel of dat de library simpelweg niet compleet is. Deze foutmelding stuur je het best naar de ROM maker, die zijn toolchain dient te controleren.

De tweede melding is dan logisch: er wordt een script uitgevoerd die root access nodig heeft. Met het “su” commando krijg je super-user rechten (a.k.a. “root access”) en die heb je niet als je de stap “su” overslaat. Dat gaat niet werken dus…

Bewerkt (24 april 2013 15:08)
kwint

kwint

  • Lid sinds 05 april 2012
  • Berichten 11
  • Reputatie 0
  • #3
  • 6 juli 2012
  • 17:03

Het opnieuw flashen van de rom heeft het probleem opgelost

Bewerkt (24 april 2013 15:10)
g-member

g-member

  • Lid sinds 19 augustus 2010
  • Berichten 294
  • Reputatie 0
  • #4
  • 6 juli 2012
  • 23:01

Wat een moeilijkheid, je kan toch simpel in recovery een ext3/4 partitie maken met een 0 cach size en daarna A2sd+ flashen.
Zou moeten werken mits het word ondersteund door de Rom.

Bewerkt (24 april 2013 15:10)

Reageer

Om te reageren, dien je te zijn ingelogd. Druk op de onderstaande knop om in te loggen of maak een nieuwe account aan.

Inloggen Registreren