Naar content
Trending apps
  • Inbox by Gmail

  • Maps: Navigatie en OV

  • WhatsApp Messenger

  • Messenger

  • Facebook

Trending games
  • Ghostbusters World

  • Asphalt 9: Legends - 2018’s New Arcade Racing Game

  • Pokémon Quest

  • PUBG Mobile

  • Super Mario Run

Trending smartphones
  • OnePlus 6T

  • Huawei Mate 20 Pro

  • Google Pixel 3 XL

  • Samsung Galaxy Note 9

  • Nokia 7 Plus

Nieuwste tablets
  • Samsung Galaxy Tab A 10.5

  • Samsung Galaxy Tab S4

  • Samsung Galaxy Tab S3 9.7

  • Asus Zenpad 3S 10

  • Sony Xperia Z4 Tablet

Lager dan Oreo wordt niet meer toegelaten

Vanaf nu moeten apps minimaal gericht zijn op Android Oreo

· 02 november 2018

Google rolt altijd nieuwe beveiligingsfuncties uit bij elke Android-versie, maar sommige wijzigingen die worden aangebracht zijn alleen van toepassing op apps die op nieuwere API-niveaus zijn gericht. Dus kondigde Google eind vorig jaar aan dat ze zouden stoppen met de toevoeging aan de Play Store van applicaties die zich richten op oudere versies van Android. Dat moment is nu zover.

Nieuw beleid

Gisteren was de grote dag - ontwikkelaars kunnen niets meer uploaden naar de Play Store zonder eerst hun app te richten op minimaal API niveau 26 (Android 8.0 Oreo). Het nieuwe beleid is vanaf 1 november volledig van kracht, maar het is iets waar ontwikkelaars al maanden mee te maken hebben. Vanaf 1 augustus is de Play Store gestopt met het accepteren van nieuwe apps die zijn gericht op Android-versies ouder dan Oreo.

Ook updates worden nu meegenomen in het nieuwe beleid en deze moeten dus ook minimaal voor Android 8.0 Oreo ontwikkeld zijn. Zelfs voor een app-update die slechts een kleine bugfix betreft is ​​API 26 nu vereist. Dat betekent dus dat deze apps genieten van de beveiligingsverbeteringen van Oreo, zoals beperkte toegang tot gebruikersaccounts.

Dat de apps ontwikkeld zijn voor Android 8.0 Oreo en hoger, betekent dat er gebruik wordt gemaakt van de verbeteringen van nieuwere Android-versies, maar deze apps zijn ook op oudere Android-versies te gebruiken. De minimale Android-versie en de versie waarop een app gericht is, staan namelijk los van elkaar.

Nokia 8 Oreo

Toekomst

Apps met oudere onveilige API's worden niet meer ondersteund maar blijven wel gewoon in de Play Store staan. De apps zijn daarnaast ook beschikbaar op versies onder Android 8.0 Oreo.

In de toekomst zal het minimaal ondersteunde API-niveau elk jaar worden verhoogd. Vanaf volgend jaar wordt het minimumdoel dus Android Pie (API level 28). Google waarschuwt ook dat een toekomstige Android-versie apps die zich richten op oude API-niveaus niet meer zal ondersteunen en dat die dus onbruikbaar worden. Het is dus vanzelfsprekend een must voor ontwikkelaars om oude apps te updaten met de minimaal vereiste API als ze willen dat mensen ze blijven gebruiken.

Android 9.0 Pie

Verder wordt vanaf augustus 2019 van alle apps vereist dat ze een 64-bits versie hebben om zo betere prestaties te leveren voor krachtigere smartphones. Dit betekent niet dat 32-bits vanaf dan niet meer wordt toegestaan, maar alleen dat er daarnaast verplicht een 64-bits versie aanwezig zal moeten zijn.

Google laat hier flagrant mee zien dat ze zich meer willen richten op een toekomst waarin apps veiliger zijn en beter presteren. 

Via: Android Developers Blog

Spelfouten, taalfouten of inhoudelijke fouten ontdekt? Stuur dan een mailtje naar de auteur van dit artikel!

Reacties (10)
Bezig met laden van reacties...